Soporte de Prestashop 1.6 disponible hasta junio de 2019

Ampliación del soporte de Prestashop 1.6 hasta junio de 2019

Prestashop, ha publicado en su blog (12/10/2018), que el soporte de la versión 1.6 se extenderá hasta junio de 2019 (Recuerdo, que oficialmente se acababa en octubre del 2018).

El soporte, principalmente se mantendrá, en actualizaciones para corregir bugs críticos y problemas de seguridad.

Por lo tanto y si las fechas no vuelven a cambiar, el soporte de Prestashop 1.6 se acabará el 30 de junio de 2019.

Información en el idioma de Shakespeare en el blog oficial de Prestashop (Imagino que, en unos días, pondrán la noticia en el idioma de Cervantes, como es habitual):

  • https://www.prestashop.com/en/blog/Maintenance-extension-PrestaShop-1-6

En mi opinión personal, sigue siendo el fin de la versión 1.6, más tarde o más temprano, al final es lo mismo. La única ventaja, es que quien no se haya pasado a Prestashop 1.7 todavía, podrá disfrutar en el año 2019, de una versión más madura a lo que nos podemos encontrar ahora en la rama de Prestashop 1.7.

* Actualización del artículo (1)

Tal como había comentado anteriormente, Prestashop, ha terminado publicando el artículo en el idioma de Cervantes (15/10/2018).

Dicha información, la podéis encontrar aquí:

  • https://www.prestashop.com/es/blog/ampliacion-mantenimiento-prestashop-1-6

Vuelven a comentar lo mismo, que el mantenimiento de la versión 1.6 se extiende hasta el 30 de junio y que “principalmente” consistirá en:

  • Corregir errores críticos y dar solución a fallos de seguridad

Por lo tanto, no se implementarán mejoras ni corregirán errores menores, solo se solucionará lo más importante, además de los problemas de seguridad que vayan surgiendo.

Comentan que están trabajando duro con Prestashop 1.7.5 y 1.7.6 (en los repositorios de código) para incluir funcionalidades que venían en Prestashop 1.6, pero que todavía no se han implementado en Prestashop 1.7, además de otras nuevas funcionalidades propias de la nueva versión.

Evidentemente, el camino de Prestashop es hacia una integración total de Symfony, que todavía no se ha cumplido, pero según comentan se terminara cumpliendo con el tiempo…


Respecto a la actualización de Prestashop 1.6 a la 1.7, como siempre digo con calma y en una copia para hacer todas las pruebas posibles. Recordar, aunque se pueda usar el módulo 1click upgrade (autoupgrade) que ofrece Prestashop:

La plantilla que estés usando, olvídate de ella.

Módulos de terceros que hayas descargado o comprado, es posible que no sean compatibles con la versión 1.7 (algunos si pueden serlos). Aunque habitualmente en el proceso de actualización de Prestashop 1.6 a 1.7, se puede indicar que desactive los módulos “no nativos” y los “override”, es importante tener apuntado que módulos estas usando que no sean los nativos.

El tema de los overrides (overrides de clases y controlados) que he comentado en el párrafo anterior, algunos overrides provienen de módulos que hayas instalado, otros es posible que los hayas creado para incluir nuevas funcionalidades, por lo tanto, este aspecto debes tenerlo en cuenta, independientemente de que en el proceso de actualización señales que quieres desactivar los overrides.

Si recordamos, cuando salió la 1.7 a finales de 2016, ni la multitienda, ni los almacenes se encontraban implementado en dicha versión (en la 1.6 si lo estaban), con el tiempo se han ido implementando, pero, por ejemplo, la multitienda no termina de estar fina, este aspecto debes tenerlo también en cuenta antes de pensar en la actualización, como digo siempre, normalmente la actualización la vas hacer en una copia de la tienda, para hacer pruebas, es cuestión de lo que vayas viendo.

Por otro lado, aunque la mayoría de módulos nativos se han ido actualizando con el tiempo, algunos han quedado en el tintero (en proceso de actualización), este aspecto es otro que debes tener en cuenta.

Pasar de la 1.6 a la 1.7, no es solo usar el módulo 1click upgrade (autoupgrade) y pulsar “1 botón”. Es recomendable, previamente hacer un estudio de lo que tienes en la tienda, y ver si es aceptable, tanto a nivel de funcionamiento, como económico pasarlo a Prestashop 1.7 a día de hoy. Cada tienda es un mundo, y tiene sus propias particularidades.

Recuerdo, que hace unos días, publique una “alternativa” llamada “thirtybees”, por si no quieres actualizar a Prestashop 1.7, pero seguir recibiendo actualizaciones y mejoras a largo plazo (revisar información).

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *